
 Activity 5.1 Guide 

How to Create an Animated Face 

This activity walks you step by step through the process of creating a simple animation by using Macromedia 
Flash 8. You will use many basic Flash techniques, including drawing tools, motion and shape tweens, button 
symbols, and basic ActionScript to provide user controls. You will also import a sound file to provide a musical 
soundtrack while the movie plays. After you have tested your movie, you will publish it for playback by others, 
either through a browser or directly with Flash Player. 

Draw Facial Features 

Draw the right eye 

1. Start Flash and open a blank new document. 

2. The new document contains one layer and one empty 
keyframe. 

3. Select the Oval tool and draw a small circle to represent 
the right eye on a face (Figure 1). 

 Your circle may not be blue. 

4. Select the Selection tool and double-click the circle’s 
center to select it. You should see both its outline 
(stroke) and center (fill) selected. 

5. To change the outline color of the eye, click the Stroke 
Color box in the Property inspector and select a new 
color (Figure 2). To change the fill color, use the Fill 
Color box. 

6. On the Timeline, double-click the layer name, Layer 1 
(Figure 3). 

 This selects the layer name so you can rename it. 

7. Rename the layer Right Eye and press Enter (Windows) 
or Return (Macintosh) (Figure 4). 

 

 
Figure 1 Right eye drawn with Oval tool 

 

 

Figure 2 Image Property inspector 

 

 
Figure 3 Layer name 

 

 
Figure 4 New layer name 
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Save the eye graphic as a symbol in the library 

Instead of creating two eyes separately, convert the right eye 
from a shape to a graphic symbol. This adds the eye to the 
library so you can use it over and over. This will also reduce 
the size of your finished movie. 

8. On the Right Eye layer, click frame 1 to select it 
(Figure 5). 

 This automatically selects the contents of frame 1. 

 Note: If the right eye is not completely selected, double-
click the eye on the Stage with the Selection tool to 
select it. 

9. Select Modify > Convert to Symbol. 

 The Convert to Symbol dialog box opens (Figure 6). 

10. In the dialog box, name the symbol eye, select Graphic 
as the behavior, and click OK (Figure 7). 

 The eye on the Stage is now just an instance (copy) of 
the master eye symbol, which is stored in the library. 
The eye now has a single blue selection border and can 
be selected with a single click. 

11. Select Window > Library to see that your symbol has 
been added to the Library panel (Figure 8). 

 Note: You must select the eye symbol in the library to 
see the graphic in the preview window. 

 You can now reuse the eye symbol as many times as 
you want without redrawing it. 

 

 

 
Figure 5 Frame 1 selected 

 

 
Figure 6 Convert to Symbol dialog box 

 

 
Figure 7 Symbol name 

 

 
Figure 8 Library panel 
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Reuse the eye symbol to create the left eye 

12. Click the Insert Layer button in the lower left corner of 
the Timeline to insert a new layer (Figure 9). 

13. Double-click the layer name and change the name to 
Left Eye. 

14. On the Left Eye layer, select frame 1. 

15. Select the eye symbol in the Library panel and drag the 
symbol onto the Stage (Figure 10).  

 You now have a second instance of the eye on the 
Stage. Using instances from the library keeps the file 
size of your movie smaller than copying and pasting. 
Smaller movies load faster in a browser. 

 

 
Figure 9 Insert Layer button 

 

 
Figure 10 Drag eye symbol onto Stage 

Draw the nose 

16. Insert a new layer and name it Nose. 

17. Select frame 1 on the Nose layer. 

18. Select the Line tool and draw two lines that form an 
angle to represent a nose (Figure 11). 

19. To adjust the angle after you’ve drawn it, use the 
Subselection tool (white arrow) to drag one end of the 
line. (You might try dragging one end of a line with the 
Arrow tool to see the difference between the two tools.)

 

 
Figure 11 Draw nose 
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Add frames to make a three-second movie 

A Flash movie typically plays 12 frames per second. To keep the nose on the Stage for 3 seconds, for example, you 
need to insert 36 additional frames on the Nose layer after frame 1, the current frame. (Starting at frame 1, it will 
take the movie 3 seconds to reach frame 37, because 1 + 36 = 37.) 

20. Select frame 37 on the Nose layer and select 
Insert > Timeline > Frame.  

 Flash inserts frames through frame 37 (Figure 12). 
Observe that the playhead (the red rectangle at the top 
of the Timeline) is on frame 37 and that the nose is 
visible but the eyes have disappeared. At the bottom of 
the Timeline, you can see that this movie is currently 37 
frames, is set to play at 12 frames per second, and will 
play for 3 seconds. 

 Note: The keyboard shortcut for inserting a frame is F5. 

21. Drag the playhead to various frames. 

 The nose remains visible in frames 1 through 37, but the 
eyes appear only in frame 1. 

22. To see your movie, drag the playhead to frame 1 and 
then select Control > Play. 

 At this point, not much is happening beyond frame 1. 

Figure 12 Frame inserted in Timeline 

Draw the mouth 

23. Insert a new layer and name it Mouth. 

24. Select frame 1 of the Mouth layer. 

25. Draw a mouth in frame 1. 

• Use the Line tool to draw a straight line 
(Figure 13).  

• Select the Selection tool and click on the Stage 
away from the line to deselect it.  

• Move the pointer toward the middle of the line. 
When a curve appears next to the pointer, drag the 
middle of the line downward to create a smile 
(Figure 14).  

• When you release the mouse button, only the smile 
remains (Figure 15).  

 

 
Figure 13 Mouth as straight line 

 

 

 
Figure 14 Drag line with Arrow tool 

 

 
Figure 15 Mouth complete 
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Animate the Facial Features 

Use motion tweens to animate the eyes 

Because you created the eyes by using a graphic symbol, you can animate them by using a motion tween. To create 
the motion tween, you need a start keyframe and an end keyframe containing the same symbol. You can then use a 
motion tween to fill the frames between the keyframes. 

1. On the Right Eye layer, select frame 37 and select 
Insert > Timeline > Keyframe. This will be the end 
keyframe. 

 A keyframe signals Flash that some animation action 
begins or ends at that frame. 

2. On the Right Eye layer, select frame 37 and drag the 
right eye a short distance. 

3. Select any frame between frames 1 and 36 on the Right 
Eye layer. 

4. In the Property inspector, select Motion from the 
Tween menu to create a motion tween (Figure 16). 

 Note: You can also select Insert > Timeline > 
Create Motion Tween. 

 Notice the frames containing the motion tween are now 
light blue and contain a solid arrow running from the 
start frame to the end frame. 

5. Position the playhead on frame 1 and select 
Control > Play to play your movie and see the effect of 
the motion tween. 

 The right eye gradually moves from its original position 
in frame 1 to the new position in frame 37. Notice that 
only the right eye moves. 

 Note: If you want to change the motion, move only the 
symbol in keyframe 37. 

6. Select frame 37 on the Left Eye layer and insert a 
keyframe. 

7. Move the left eye the same distance as the right eye, and 
then create a motion tween between the first and last 
frames on the Left Eye layer. 

Figure 16 Tween menu 
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Use a shape tween to animate the mouth 

Because you created the mouth by using one of the drawing tools (the Line tool) and have not converted the mouth 
to a symbol, it is still a shape. You can use a shape tween to animate the mouth. 

8. Select frame 37 on the Mouth layer and insert a 
keyframe. 

9. With the Selection tool, click on the Stage away from 
the mouth line to deselect it. Then drag the mouth line 
into a bigger smile. 

10. To create a shape tween between the first and last 
frames on the Mouth layer, click a frame between 
frames 1 and 37, and select Shape from the Tween 
menu in the Property inspector. 

 Notice the frames containing the shape tween are now 
light green and contain a solid arrow running from the 
start frame to the end frame.  

10. Select File > Save. 

11. Select Control > Test Movie to see it play. 

 Selecting Control > Test Movie exports a .swf file and 
plays it in a preview window. When the movie reaches 
the last frame, it loops back to frame 1 and plays again. 

12. Select File > Close to close the preview window. 

Create any additional animated facial features as you choose.
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Add User Control 

In Flash you can use ActionScript to enable the viewer to control a movie. You use frame actions to tell the movie 
what to do when it reaches a specific frame. You use object actions to associate the control with an object such as a 
button symbol. Object actions, such as button actions, let you give your visitors more control over the movie. 

For example: 

• You can attach a stop action to the first frame of your movie so the movie will not play past frame 1 until 
the viewer makes that happen. 

• You can add a Start button in the first frame of your movie and attach a goto action so the movie will 
resume playing when the viewer clicks the Start button. 

• You can add a Stop button that will be available after the viewer clicks the Start button. If you attach a stop 
action to the Stop button, the movie will stop when the viewer clicks the button. 

Attach a stop action to the first frame 

1. Select the top layer on the Timeline and insert a new 
layer. 

 The new layer is inserted at the top of the list. 

 Note: A new layer is always inserted above the 
currently selected layer. To change the order of layers 
on the Timeline, select a layer and drag it to the desired 
position in the list. 

2. Name the new layer Actions. 

3. Select the first frame of the Actions layer. 

 This is where you will place the stop action telling the 
movie to stop and not begin playing automatically. 

4. Select Window > Actions. 

 The Actions Panel opens (Figure 17). Notice that the 
panel title bar reads Actions – Frame. This is because 
you are applying an action to a frame, not to a button or 
movie clip. 

5. Make sure Script Assist is on (the right pane will appear 
split, as in Figure 17). If it is not, click the Script Assist 
button. 

 Script Assist makes it easier to add ActionScript to your 
Flash documents by letting you fill in dialog boxes 
instead of directly writing code. 

6. In the Actions toolbox, click the Global Functions 
category to display subcategories of actions (Figure 18).

 
 

 

Figure 17 Actions panel 

 

 
Figure 18 Global functions category expanded 
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7. Click the Timeline Control category to expand it 
(Figure 19).  

8. Select the stop action. To attach the stop action to frame 
1, either double-click the stop icon or drag it to the 
Script pane. 

9. Close the Actions panel and look in frame 1 of the 
Actions layer. 

 The frame contains a small letter a indicating this frame 
contains an action (Figure 20).  

Figure 19 Timeline control category expanded 

 

Figure 20 Frame with action added 

Create a Start button 

Now that you’ve placed a stop action in frame 1, you need to create an object action giving the user the ability to 
start the movie. The object action needs to be associated with an object, so first create a Start button. 

10. Insert a new layer and name it Buttons. 

11. Select frame 1 on the Buttons layer, and select 
Insert > New Symbol. 

 The Create New Symbol dialog box opens. 

12. Name the symbol Start, select Button for the Behavior, 
and click OK (Figure 21). 

 Flash switches to symbol-editing mode, with a new 
blank Stage for your button symbol. The name of your 
button appears on the information bar at the top of the 
Stage (Figure 22). 

 The Timeline displays four frames for the four states of 
a button (Figure 23). Each frame (or button state) has a 
specific function: 

• The Up state represents the button’s appearance 
when the pointer is not over the button. 

• The Over state represents the button’s appearance 
when the pointer is over the button. 

• The Down state represents the button’s appearance 
as it is clicked. 

• The Hit state defines the target area that responds to 
a mouse click. This area is not visible when the 
movie plays. 

Figure 21 Create New Symbol dialog box 

 

 
Figure 22 Symbol-editing mode 

 

 
Figure 23 Button Timeline 
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13. Select the Up frame. 

14. Use the Rectangle tool to draw a rectangular button on 
the Stage. Use the Property inspector to set stroke and 
fill colors for the Up state of the button. 

15. Insert keyframes in the Over, Down, and Hit frames. 

 By inserting keyframes, you automatically copy the 
rectangle to the other states of the button. 

 Note: Flash automatically inserts a keyframe in the Up 
frame. 

16. Select the Over frame. Using the Selection tool, double-
click the button on the Stage to select it, and change the 
stroke or fill color for the Over state in the Property 
inspector. 

17. Select the Down frame. Using the Selection tool, 
double-click the button on the Stage and change the 
stroke or fill color for the Down state. 

18. Select the Hit frame. Use the Rectangle tool to draw a 
rectangular target area that will respond to a mouse 
click. 

 Note: It doesn’t matter what colors you use for the Hit 
area, because this rectangle is not visible to viewers of 
your movie. If you skip this step, Flash will 
automatically define the target area to be the same as the 
button shape. 

19. Insert a layer and name it Text. 

20. Select the Up frame on the Text layer and use the Text 
tool to type Start. Use the Property inspector to change 
the font, size, and color of the text. Center the text 
within the rectangle shape. 

21. To exit symbol-editing mode and return to editing the 
movie, click Scene 1 on the information bar at the top of 
the Stage or select Edit > Edit Document. 

 Your Start button does not appear on the Stage yet, but 
it is stored in the library. 
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Create a Stop button 

You can repeat the steps you used to create the Start button, or you can simply duplicate and then modify the Start 
button. 

22. Make sure the Library panel is open. (If not, select 
Window > Library.) 

23. Select the Start button symbol in the library. 

24. Select Duplicate from the Library panel options menu 
in the upper right corner of the panel (Figure 24). 

 The Duplicate Symbol dialog box opens (Figure 25). 

25. Make sure Button is selected for Behavior. Name the 
new symbol Stop and click OK. 

26. In the Library panel, double-click the icon for the Stop 
symbol to edit the symbol (Figure 26). 

27. Select frame 1 of the text layer, and use the Text tool to 
edit the text to read Stop. 

28. Click Scene 1 or select Edit > Edit document to exit 
symbol-editing mode. 

 
Figure 24 Library panel options menu 

 

Figure 25 Duplicate Symbol dialog box 

 

 
Figure 26 Edit Stop symbol 
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Place the buttons on the Stage 

29. Select frame 1 on the Buttons layer. 

30. Make sure the Library panel is open. (If not, select 
Window > Library.) 

31. Drag the Start button from the library onto the Stage. 

32. Select frame 2 on the Buttons layer and insert a 
keyframe. 

33. Delete the Start button from frame 2. 

34. Drag the Stop button onto the Stage. 

35. Click the Onion Skin Outlines button at the bottom of 
the Timeline (Figure 27). 

 With onion skinning turned on, you can view a range of 
frames. This will help you align the Start and Stop 
buttons. 

36. Move the Start and Stop buttons until both of them are 
in the same position on the Stage. 

 Note: To fine-tune the position of the buttons, select a 
button and use the up, down, left, and right arrow keys. 

37. Click the Onion Skin Outlines button again to turn off 
onion-skinning. 

Figure 27 Onion Skin Outlines button 

Add button actions 

38. Select frame 1 on the Buttons layer, select the Start 
button on the Stage, and open the Actions panel 
(Window > Actions). 

 Note: Be sure to select the Start button, or your action 
will be applied to the frame, not the button. The Action 
panel’s title bar should say Actions - Button. 

39. Make sure Script Assist is turned on (Figure 28). If you 
don’t see the Parameters area, click the Script Assist 
button. 

40. In the Actions toolbox, expand the Global Functions 
and Timeline categories and drag goto to the lower 
right panel. 

 Flash automatically adds an on(release) command to the 
script along with the goto action. This means the goto 
action executes when the visitor releases the Start 
button. 

41. Make sure Go to and Play is selected in the parameters 
area. 

 

Figure 28 Script Assist turned on 

Parameters area Script pane 

 

 How to Create an Animated Face   5 - 53 



Activity 5.1 Guide 

42. Be sure the setting for Scene in the parameters area is 
<Current scene>, and Type is Frame Number. For 
Frame, type 2. 

 This action will start the animation in frames 2 through 
37. 

 Notice that the settings you made in the parameters area 
are reflected in the Script pane at the bottom of the 
panel. This is the ActionScript that controls the actions 
in your movie (Figure 29). 

43. Select frame 2 on the Buttons layer and select the Stop 
button. 

 Note: You may need to collapse the Actions panel to 
see the layers. To collapse the Actions panel, click the 
down arrow on the title bar. 

44. Make sure the Actions panel is expanded, and double-
click goto. 

45. In the parameters area of the Actions panel, select Go to 
and Stop. For Frame, type 1. 

 This action will stop the animation and redisplay the 
Start button in frame 1. 

 Next, make the movie loop through frames 2–37 until 
the viewer clicks Stop. You do this by using a Frame 
action. 

46. Insert a keyframe in frame 37 of the Actions layer. 

47. In the Actions panel, double-click goto. 

48. In the parameters area, select Go to and Play, and type 
2 for Frame. 

49. Close the Actions panel, save your movie, and select 
Control > Test Movie to test it. 

50. Select File > Close to close the preview window. 

Figure 29 Parameters for the goto action 
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Add Sound 

1. Insert a new layer below the Actions layer and name it 
Sound. 

2. Select File > Import > Import to Library. 

 The Import to Library dialog box opens. 

3. Locate and select a sound file saved on your computer. 
Click Open (Windows) or Import to Library 
(Macintosh). 

 The sound is added to the library. 

 Note: You can download free music loops and sound-
effect clips at www.flashkit.com, for example. 

4. Select frame 2 on the Sound layer and insert a keyframe.

5. Open the library and drag the sound file from the library 
onto the Stage. 

 Flash inserts the sound on the Sound layer, starting in 
frame 2. 

6. Select frame 2 on the Sound layer. In the Property 
inspector, select Start from the first Sync menu and 
select Loop from the second Sync menu (Figure 30). 

7. To stop the sound when the viewer clicks the Stop 
button: 

• Select frame 2 on the Buttons layer. 

• Select the Stop button. 

• Select Window > Actions. 

• Double-click stopAllSounds in the Movie Control 
category of the Actions toolbox. 

• Close the Actions panel. 

• Save the movie and test it. 

Figure 30 Sound Property inspector 
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Publish Your Movie 

When you’re ready to deliver your movie to an audience, you can publish the Flash document (FLA file) for 
playback. The Publish command creates a Flash SWF file (playable with Flash Player) and an HTML document that 
inserts your Flash movie in a browser window. For viewers who do not have Flash Player installed, you can select 
to publish the FLA file in alternative file formats—GIF, JPEG, PNG, or QuickTime—with the HTML needed to 
display them in a browser window. 

1. Select File > Publish Settings to open the Publish 
Settings dialog box (Figure 31). 

2. Use the Formats tab to determine which file formats to 
output when you publish. 

3. Use the Flash tab to determine which Flash Player you 
are publishing to (Figure 32). If you think your 
audience might not have the latest player, you might 
want to select an older player. 

4. Select Generate Size Report to see a detailed report of 
size for each asset in your movie. 

5. Select Protect from Import to prevent anyone from 
importing your SWF file into Flash and converting it 
back to a FLA file. 

6. Select Compress Movie to reduce the file size of the 
exported movie.  

Figure 31 Publish Settings dialog box 

 

 
Figure 32 Flash tab of Publish Settings dialog box

 

5 - 56   How to Create an Animated Face 



 Activity 5.1 Guide 

7. Use the HTML tab to control settings for the HTML 
file (Figure 33). 

8. To publish your movie, click the Publish button. 
 

 
Figure 33 HTML tab of Publish Settings dialog 
box 
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